<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
 <meta name="viewport" content="width=930">
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta names="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="apple-itunes-app" content="app-id=562577281" />
<meta name="google-play-app" content="app-id=com.boxing.boxingnews" />
<meta name="apple-touch-icon" href="/apple-touch-icon.png" />
<link rel="apple-touch-icon-precomposed" href="/apple-touch-icon.png" />

	<title>Gervonta Davis Stops Jesus Cuellar - Boxing.com</title>
	<meta name="description" content="Boxing news about Gervonta Davis Stops Jesus Cuellar by Robert Ecksel at Boxing.com. Ultimate Source for Latest Boxing News" />
	<meta name="keywords" content="Boxing, gervonta davis, jesus marcelo andres cuellar, boxing community" />
<!-- CSS -->
<link href="http://www.boxing.com/css/general.css" rel="stylesheet" type="text/css" media="screen"/>
<link rel="stylesheet" href="http://www.boxing.com/css/jquery.smartbanner.css" type="text/css" media="screen">
	<link href="http://www.boxing.com/css/article.css" rel="stylesheet" type="text/css" />
<script type="text/javascript" src="http://www.boxing.com/js/jquery-1.8.3.min.js"></script>
<script type="text/javascript" src="http://www.boxing.com/js/jquery.smartbanner.js"></script>
<script type="text/javascript" src="http://www.boxing.com/js/common.js"></script>
<!--[if IE 6]>
<script type="text/javascript" src="http://www.boxing.com/js/belatedpng.js"></script>
<![endif]-->
<!--[if IE 6]>
<script type="text/javascript">
	DD_belatedPNG.fix('#header a.logo,#rotator .desc');
</script>
<![endif]-->
<script type="text/javascript" src="http://www.boxing.com/js/buysellads.js"></script>
	<script type="text/javascript" src="http://www.boxing.com/js/article.js"></script>
	<script type="text/javascript" src="https://apis.google.com/js/plusone.js"></script>
<!-- RSS -->
<link href="http://www.boxing.com/news/rss" rel="alternate" type="application/rss+xml" title="RSS Feed" />
<!-- Favicon -->

	      
</head>
	
	<body>
<div id="wrap" class="wrap">
	<div id="main">
<div id="mobile-message" style="display: none; z-index: 16777271; position: fixed; top: 0px; width: 920px; text-align: center; border: none; background-color: rgb(245, 221, 136); color: rgb(0, 0, 0); overflow: hidden; text-align: center; font-size: 3.5em; font-family: arial; padding: 0 0 8px 0; ">
Please check our <a href="https://itunes.apple.com/app/boxing-news-and-results/id562577281" style="color: #000; font-weight: bold; text-decoration: none; border-bottom: 1px solid #000;" rel="nofollow">iPhone/iPad</a>,<br><a href ="https://play.google.com/store/apps/details?id=com.boxing.boxingnews" style="color: #000; font-weight: bold; text-decoration: none; border-bottom: 1px solid #000;" rel="nofollow">Android</a> and <a href="http://www.boxing.com/m/index.php" style="color: #000; font-weight: bold; text-decoration: none; border-bottom: 1px solid #000;">Web mobile</a> versions.
<a id="mobile-close" href="#" onclick="this.parentNode.style.display = 'none'; return false;" style="display: block; width: 2em; height: 1.6em; background-color: rgb(180, 141, 4); border: none; color: rgb(255, 255, 255); text-decoration: none; position: absolute; right: 0px; top: 0px; ">×</a>
</div>
<script type="text/javascript">
if( document.referrer != null && !/boxing\.com/i.test(document.referrer) && /webOS|BlackBerry|Mobile|phone|mini/i.test(navigator.userAgent) && !/Android|iphone|iPad|iPod|/i.test(navigator.userAgent) ) {
document.getElementById("mobile-message").style.display = 'block';
}
</script>

<div style="text-align: center;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Boxing.com Leaderboard -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-0736880289040706"
     data-ad-slot="2210863252"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

		<div id="header">
			<h1 class="linline">
				<a class="logo" title="Main Page Boxing.com" href="http://www.boxing.com/">Boxing.com</a>
			</h1>
			<ul class="menu rinline">
				<li><a href="http://www.boxing.com/latest-news">NEWS</a></li>
				<li><a href="http://www.boxing.com/blog">BLOG</a></li>
				<li><a href="http://www.boxing.com/ranking">RANKING</a></li>
				<li><a href="http://www.boxing.com/schedule">SCHEDULE</a></li>
				<li><a href="http://www.boxing.com/results">RESULTS</a></li>
				<li><a href="http://www.boxing.com/video">VIDEO</a></li>
				<li><a href="http://www.boxing.com/exclusive">EXCLUSIVE</a></li>
			</ul>
		</div>
		<div id="subheader">
			<form method="post" action="">

				<div class="linline">
					<b>FIGHTS:</b>
<span class="fighter_1"><a href="http://www.boxing.com/what_to_watch_april_19_21.html">Weekend Fights on TV</a></span>
				</div>

				<ul class="rinline">
					<li class="tw"><a href="http://twitter.com/#!/Boxing_com" target="_blank"><img src="http://www.boxing.com//images/twitter.png" height="16" width="16" alt=""/></a><span class="for_ie6"></span></li>
					<li class="fb"><a href="http://www.facebook.com/pages/Boxingcom/213858341985184" target="_blank"><img src="http://www.boxing.com//images/facebook.jpg" height="16" width="16" alt=""/></a></li>
					<li><a href="http://www.boxing.com/member/register">Sign Up</a></li>
					<li class="last"><a href="http://www.boxing.com/member/login">Log In</a></li>

					<li class="search">
<form method="post" action="http://www.boxing.com/"  >
<div class='hiddenFields'>
<input type="hidden" name="ACT" value="20" />
<input type="hidden" name="XID" value="4f9119774a5c2c82ebfa216cd0962eaac828271c" />
<input type="hidden" name="RES" value="4" />
<input type="hidden" name="meta" value="YTo4OntzOjY6InN0YXR1cyI7czowOiIiO3M6NzoiY2hhbm5lbCI7czoyMzoid2VibmV3c3xuZXdzfHZpZGVvfGJsb2ciO3M6OToic2VhcmNoX2luIjtzOjEwOiJldmVyeXdoZXJlIjtzOjU6IndoZXJlIjtzOjM6ImFsbCI7czoxMjoic2hvd19leHBpcmVkIjtzOjA6IiI7czoxOToic2hvd19mdXR1cmVfZW50cmllcyI7YjowO3M6MTE6InJlc3VsdF9wYWdlIjtzOjE0OiJzZWFyY2gvcmVzdWx0cyI7czoxNToibm9fcmVzdWx0c19wYWdlIjtzOjE0OiJzZWFyY2gvcmVzdWx0cyI7fWQyYjg3OWYyMjlkMTJjZDgwYjZkOWM1MGQ3ZjMxY2U1" />
<input type="hidden" name="site_id" value="1" />
</div>


						<input class="search_field" type="text" name="keywords" value="Search..." onFocus="if(this.value == 'Search...'){this.value='';}"/>
						<input class="search_button" type="submit" name="submit" value=" " />
</form>
					</li>
				</ul>
			</form>
		</div>
<!--CONTENT_START-->

<div id="content" class="clearfix">
			<div class="index linline">

				<div class="post">

					<h2 class="title">Gervonta Davis Stops Jesus Cuellar</h2>
                                        					<div class="data">By <a href="http://www.boxing.com/Robert-Ecksel-writer-2/">Robert Ecksel</a> on April 21, 2018</div>
                                        
					
					<img src="/images/sized/images/articles/gervonta_davis_uppercut_wescott2-530x317.jpg" alt="Gervonta Davis Stops Jesus Cuellar" width="530" height="317" />

															<div class="review">
						He might develop into one of the great fighters of our time. (Amanda Wescott/Showtime)
					</div>
										<div id="fb-root" style="padding-top: 10px;"></div><script src="http://connect.facebook.net/en_US/all.js#appId=179552082105900&amp;xfbml=1"></script><fb:like href="http://www.facebook.com/pages/Boxingcom/213858341985184" send="true" width="500" show_faces="false" font=""></fb:like>
										    					<div class="info">
					    
						<p>Gervonta Davis stopped Jesus Cuellar at 2:45 of round three to win the WBA Super World super featherweight title…</p>


					    
					</div>
					    					<div class="story">
					    
						<p>Saturday night at the Barclays Center in Brooklyn, New York, in a battle of southpaws, Gervonta “Tank” Davis (20-0, 19 KOs), from Baltimore, Maryland, stopped former featherweight champion Jesus “El Jinete” Cuellar (28-3, 21 KOs), from Jose C. Paz, Buenos Aires, Argentina, at 2:45 of round three to win the WBA super featherweight title.</p>

<p>Fighting out of the blue corner in white trunks with burgundy trim, Davis, ranked number three by the WBA, dropped his opponent three times, once in the second and twice in the third, on his way to an early stoppage.</p>

<p>Cuellar, fighting out of the red corner in white trunks with gold and red trim, was coming up in weight after a year and a half of inactivity. He also had nine years on 23-year-old Davis, who has not yet hit his fighting prime.</p>

<p>If he can keep his wits about him, Gervonta Davis, with his power, speed, and high ring IQ, has the potential to develop into one of the great fighters of our time.</p>
					    
											</div>
					<div>
<em>Follow us on <a href="http://twitter.com/#!/boxing_com" target="_blank" >Twitter@boxing_com</a> to continue the discussion</em>
</div>
<br>
		        

					
				</div>
<div class="tags" style="">
Tags: 

<a href="/tag/gervonta+davis">gervonta davis</a> 

<a href="/tag/jesus+marcelo+andres+cuellar">jesus marcelo andres cuellar</a> 

<a href="/tag/Robert+Ecksel">Robert Ecksel</a> 

<br><br>
</div>

<div style="padding-bottom: 15px;">
<ul class="social_bookmarks">
<li class="first"><a rel="nofollow" href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fwww.boxing.com%2Fdavis_tkos_cuellar.html&amp;t=Gervonta%20Davis%20Stops%20Jesus%20Cuellar" title="Facebook" target="_blank" onclick="window.open(this.href,'_blank','height=520,width=570');return false;"><img src="/images/social-bookmarks/facebook.png" alt="Facebook" /></a></li>
<li><a rel="nofollow" href="http://twitter.com/share?url=http%3A%2F%2Fwww.boxing.com%2Fdavis_tkos_cuellar.html&amp;text=Gervonta%20Davis%20Stops%20Jesus%20Cuellar:" title="Twitter" target="_blank" onclick="window.open(this.href,'_blank','height=520,width=570');return false;"><img src="/images/social-bookmarks/twitter.png" alt="Twitter" /></a></li>
<li><a rel="nofollow" href="http://www.linkedin.com/shareArticle?mini=true&amp;url=http%3A%2F%2Fwww.boxing.com%2Fdavis_tkos_cuellar.html&amp;title=Gervonta%20Davis%20Stops%20Jesus%20Cuellar&amp;source=Boxing.com&amp;summary=" title="LinkedIn" target="_blank" onclick="window.open(this.href,'_blank','height=520,width=570');return false;"><img src="/images/social-bookmarks/linkedin.png" alt="LinkedIn" /></a></li>
<li><g:plusone size="small" count="false"></g:plusone></li>
<li><a rel="nofollow" href="http://pinterest.com/pin/create/button/?url=http%3A%2F%2Fwww.boxing.com%2Fdavis_tkos_cuellar.html&amp;media=http%3A%2F%2Fwww.boxing.com%2Fimages%2Farticles%2Fgervonta_davis_uppercut_wescott2.jpg&amp;description=Gervonta%20Davis%20Stops%20Jesus%20Cuellar" title="Pinterest" target="_blank"><img src="/images/social-bookmarks/pinterest.png" alt="Pinterest" /></a></li>
<li><a rel="nofollow" href="mailto:?subject=Gervonta%20Davis%20Stops%20Jesus%20Cuellar&amp;body=http%3A%2F%2Fwww.boxing.com%2Fdavis_tkos_cuellar.html" title="E-mail"><img src="/images/social-bookmarks/email.png" alt="E-mail" /></a></li>
<li><a rel="nofollow" href="http://del.icio.us/post?url=http%3A%2F%2Fwww.boxing.com%2Fdavis_tkos_cuellar.html&amp;title=Gervonta%20Davis%20Stops%20Jesus%20Cuellar&amp;notes=" title="Del.icio.us" target="_blank"><img src="/images/social-bookmarks/delicious.png" alt="Del.icio.us" /></a></li>
<li><a rel="nofollow" href="http://digg.com/submit?phase=2&amp;url=http%3A%2F%2Fwww.boxing.com%2Fdavis_tkos_cuellar.html&amp;title=Gervonta%20Davis%20Stops%20Jesus%20Cuellar&amp;bodytext=" title="Digg" target="_blank"><img src="/images/social-bookmarks/digg.png" alt="Digg" /></a></li>
<li><a rel="nofollow" href="http://www.evernote.com/clip.action?url=http%3A%2F%2Fwww.boxing.com%2Fdavis_tkos_cuellar.html&amp;title=Gervonta%20Davis%20Stops%20Jesus%20Cuellar" title="Evernote" target="_blank"><img src="/images/social-bookmarks/evernote.png" alt="Evernote" /></a></li>
<li><a rel="nofollow" href="http://www.friendfeed.com/share?title=Gervonta%20Davis%20Stops%20Jesus%20Cuellar&amp;link=http%3A%2F%2Fwww.boxing.com%2Fdavis_tkos_cuellar.html" title="FriendFeed" target="_blank"><img src="/images/social-bookmarks/friendfeed.png" alt="FriendFeed" /></a></li>
<li><a rel="nofollow" href="http://www.friendster.com/sharer.php?u=http%3A%2F%2Fwww.boxing.com%2Fdavis_tkos_cuellar.html&amp;t=Gervonta%20Davis%20Stops%20Jesus%20Cuellar" title="Friendster" target="_blank"><img src="/images/social-bookmarks/friendster.png" alt="Friendster" /></a></li>
<li><a rel="nofollow" href="http://www.google.com/bookmarks/mark?op=edit&amp;bkmk=http%3A%2F%2Fwww.boxing.com%2Fdavis_tkos_cuellar.html&amp;title=Gervonta%20Davis%20Stops%20Jesus%20Cuellar&amp;annotation=" title="Google Bookmarks" target="_blank"><img src="/images/social-bookmarks/google.png" alt="Google Bookmarks" /></a></li>
<li><a rel="nofollow" href="https://favorites.live.com/quickadd.aspx?marklet=1&amp;url=http%3A%2F%2Fwww.boxing.com%2Fdavis_tkos_cuellar.html&amp;title=Gervonta%20Davis%20Stops%20Jesus%20Cuellar" title="Windows Live" target="_blank"><img src="/images/social-bookmarks/live.png" alt="Windows Live" /></a></li>
<li><a rel="nofollow" href="http://www.myspace.com/Modules/PostTo/Pages/?u=http%3A%2F%2Fwww.boxing.com%2Fdavis_tkos_cuellar.html&amp;t=Gervonta%20Davis%20Stops%20Jesus%20Cuellar" title="MySpace" target="_blank"><img src="/images/social-bookmarks/myspace.png" alt="MySpace" /></a></li>
<li><a rel="nofollow" href="http://www.netvibes.com/share?title=Gervonta%20Davis%20Stops%20Jesus%20Cuellar&amp;url=http%3A%2F%2Fwww.boxing.com%2Fdavis_tkos_cuellar.html" title="Netvibes" target="_blank"><img src="/images/social-bookmarks/netvibes.png" alt="Netvibes" /></a></li>
<li><a rel="nofollow" href="http://www.newsvine.com/_tools/seed&amp;save?u=http%3A%2F%2Fwww.boxing.com%2Fdavis_tkos_cuellar.html&amp;h=Gervonta%20Davis%20Stops%20Jesus%20Cuellar" title="Newsvine" target="_blank"><img src="/images/social-bookmarks/newsvine.png" alt="Newsvine" /></a></li>
<li><a rel="nofollow" href="http://posterous.com/share?linkto=http%3A%2F%2Fwww.boxing.com%2Fdavis_tkos_cuellar.html&amp;title=Gervonta%20Davis%20Stops%20Jesus%20Cuellar&amp;selection=" title="Posterous" target="_blank"><img src="/images/social-bookmarks/posterous.png" alt="Posterous" /></a></li>
<li><a rel="nofollow" href="http://reddit.com/submit?url=http%3A%2F%2Fwww.boxing.com%2Fdavis_tkos_cuellar.html&amp;title=Gervonta%20Davis%20Stops%20Jesus%20Cuellar" title="Reddit" target="_blank"><img src="/images/social-bookmarks/reddit.png" alt="Reddit" /></a></li>
<li><a rel="nofollow" href="http://sphinn.com/index.php?c=post&amp;m=submit&amp;link=http%3A%2F%2Fwww.boxing.com%2Fdavis_tkos_cuellar.html" title="Sphinn" target="_blank"><img src="/images/social-bookmarks/sphinn.png" alt="Sphinn" /></a></li>
<li><a rel="nofollow" href="http://www.stumbleupon.com/submit?url=http%3A%2F%2Fwww.boxing.com%2Fdavis_tkos_cuellar.html&amp;title=Gervonta%20Davis%20Stops%20Jesus%20Cuellar" title="StumbleUpon" target="_blank"><img src="/images/social-bookmarks/stumbleupon.png" alt="StumbleUpon" /></a></li>
<li><a rel="nofollow" href="http://www.tumblr.com/share?v=3&amp;u=http%3A%2F%2Fwww.boxing.com%2Fdavis_tkos_cuellar.html&amp;t=Gervonta%20Davis%20Stops%20Jesus%20Cuellar&amp;s=" title="Tumblr" target="_blank"><img src="/images/social-bookmarks/tumblr.png" alt="Tumblr" /></a></li>
<li><a rel="nofollow" href="http://vkontakte.ru/share.php?url=http%3A%2F%2Fwww.boxing.com%2Fdavis_tkos_cuellar.html&amp;title=Gervonta%20Davis%20Stops%20Jesus%20Cuellar" title="VKontakte" target="_blank" onclick="window.open(this.href,'_blank','height=260,width=570');return false;"><img src="/images/social-bookmarks/vkontakte.png" alt="VKontakte" /></a></li>
<li class="last"><a rel="nofollow" href="http://bookmarks.yahoo.com/toolbar/savebm?opener=tb&amp;u=http%3A%2F%2Fwww.boxing.com%2Fdavis_tkos_cuellar.html&amp;t=Gervonta%20Davis%20Stops%20Jesus%20Cuellar&amp;d=" title="Yahoo! Bookmarks" target="_blank"><img src="/images/social-bookmarks/yahoo.png" alt="Yahoo! Bookmarks" /></a></li>
</ul>
</div>


<div style="padding-bottom: 15px;">
<a href="http://www.boxing.com/forums/viewthread/7126">Discuss this in our forums</a>
</div>



				<h2 class="index_title">Related Articles</h2>
				<ul class="related_articles clearfix">
					<li style="min-height: 114px;">

						<a href="http://www.boxing.com/broner_and_vargas_majority_draw.html">
										<img src="http://www.boxing.com/images/articles/broner_vargas_fight_night_-_WESTCOTT-0032_4.jpg" alt="" width="120" height="72" />
												<span class="title">Broner and Vargas Majority Draw</span>
						</a>

					</li>

					<li style="min-height: 114px;">

						<a href="http://www.boxing.com/charlo_flattens_centeno_jr.html">
										<img src="http://www.boxing.com/images/articles/Charlo_vs_Centeno_Jr.jpg" alt="" width="120" height="72" />
												<span class="title">Charlo Flattens Centeno Jr.</span>
						</a>

					</li>

					<li style="min-height: 114px;">

						<a href="http://www.boxing.com/khan_slaughters_lo_greco.html">
										<img src="http://www.boxing.com/images/articles/nintchdbpict0004006264331.jpg" alt="" width="120" height="72" />
												<span class="title">Khan Slaughters Lo Greco</span>
						</a>

					</li>

					<li style="min-height: 114px;">

						<a href="http://www.boxing.com/what_to_watch_april_19_21.html">
										<img src="http://www.boxing.com/images/articles/775x425-Boxing-Broner-Vargas-2018-WFAN-Promo.jpg" alt="" width="120" height="72" />
												<span class="title">What to Watch: April 19-21</span>
						</a>

					</li>
</ul>







<script type="text/javascript"><!--
google_ad_client = "ca-pub-0736880289040706";
/* Boxing.com Comment */
google_ad_slot = "5265270696";
google_ad_width = 530;
google_ad_height = 74;
//-->
</script>
<script type="text/javascript"
src="http://pagead2.googlesyndication.com/pagead/show_ads.js">
</script>



<div style="padding-right: 18px;">

<a name="comments"></a>
			

				
				
				<h2 class="index_title">Leave a comment</h2>

			<form id="comment_form" method="post" action="http://www.boxing.com/"  >
<div class='hiddenFields'>
<input type="hidden" name="ACT" value="16" />
<input type="hidden" name="RET" value="http://www.boxing.com/news/comments/davis_tkos_cuellar" />
<input type="hidden" name="URI" value="news/comments/davis_tkos_cuellar" />
<input type="hidden" name="PRV" value="news/comment_preview" />
<input type="hidden" name="XID" value="5bdb582ddd7e35eb6207cb65970aa1fe416a84e6" />
<input type="hidden" name="entry_id" value="47485" />
<input type="hidden" name="site_id" value="1" />
</div>


			    <fieldset id="comment_fields">
							<label for="name" style="display:block; font-size:13px">
					<input class="field" type="text" id="name" name="name" value="Your Name" size="50" onclick="if(this.value='Your Name') this.value='';" />
				</label>
				<label for="email">
					<input class="field" type="text" id="email" name="email" value="Email" size="50" onclick="if(this.value='Email') this.value='';" />
				</label>
				<label for="location">
					 <input class="field" type="text" id="location" name="location" value="Location" size="50" onclick="if(this.value='Location') this.value='';" />
				</label>
				<label for="url">
					<input class="field" type="text" id="url" name="url" value="Website" size="50" onclick="if(this.value='Website') this.value='';" />
				</label>
									
							<label for="comment" class="comment">
					<textarea id="comment" class="field" style="" name="comment" rows="10" cols="70"></textarea>
							</label>
						    </fieldset>

			    <fieldset id="comment_action">
			    								<label for="save_info"><input class="field" style="width: 10px;height: 10px;" type="checkbox" name="save_info" value="yes"  />&nbsp;Remember my personal info?  </label>
								<label for="notify_me"><input class="field" style="width: 10px;height: 10px;" type="checkbox" id="notify_me" name="notify_me" value="yes"  />&nbsp;Notify me of follow-up comments </label>

								<div id="captcha_box">
				    <span><img src="http://www.boxing.com/images/captchas/1524388408.3777.jpg" width="140" height="30" style="border:0;" alt=" " /></span>
				</div>
				<label for="captcha">Please <a href="http://www.boxing.com/member/login">login</a> or enter the word you see in the image above:
				    <input class="field" type="text" id="captcha" name="captcha" value="" maxlength="20" />
				</label>
								<input class="button" type="submit" name="submit" value="Submit" id="submit_comment" />
							    	
			    </fieldset>
			</form>



				
</div>
			</div>
			<div class="sidebar rinline">
				

				<ul class="fb_like clearfix">
					<li>
						<strong>241</strong>reads
					</li>

					<li>
						<a href="#comments"><strong>0</strong>comments</a>
					</li>
					<li class="bookmark">
						<strong><ul class="social_bookmarks">
<li class="first"><a rel="nofollow" href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fwww.boxing.com%2Fdavis_tkos_cuellar.html&amp;t=Gervonta%20Davis%20Stops%20Jesus%20Cuellar" title="Facebook" target="_blank" onclick="window.open(this.href,'_blank','height=520,width=570');return false;"><img src="/images/social-bookmarks/facebook.png" alt="Facebook" /></a></li>
<li><a rel="nofollow" href="http://twitter.com/share?url=http%3A%2F%2Fwww.boxing.com%2Fdavis_tkos_cuellar.html&amp;text=Gervonta%20Davis%20Stops%20Jesus%20Cuellar:" title="Twitter" target="_blank" onclick="window.open(this.href,'_blank','height=520,width=570');return false;"><img src="/images/social-bookmarks/twitter.png" alt="Twitter" /></a></li>
<li><a rel="nofollow" href="http://www.linkedin.com/shareArticle?mini=true&amp;url=http%3A%2F%2Fwww.boxing.com%2Fdavis_tkos_cuellar.html&amp;title=Gervonta%20Davis%20Stops%20Jesus%20Cuellar&amp;source=Boxing.com&amp;summary=" title="LinkedIn" target="_blank" onclick="window.open(this.href,'_blank','height=520,width=570');return false;"><img src="/images/social-bookmarks/linkedin.png" alt="LinkedIn" /></a></li>
<li><g:plusone size="small" count="false"></g:plusone></li>
<li><a rel="nofollow" href="http://pinterest.com/pin/create/button/?url=http%3A%2F%2Fwww.boxing.com%2Fdavis_tkos_cuellar.html&amp;media=http%3A%2F%2Fwww.boxing.com%2Fimages%2Farticles%2Fgervonta_davis_uppercut_wescott2.jpg&amp;description=Gervonta%20Davis%20Stops%20Jesus%20Cuellar" title="Pinterest" target="_blank"><img src="/images/social-bookmarks/pinterest.png" alt="Pinterest" /></a></li>
<li><a rel="nofollow" href="mailto:?subject=Gervonta%20Davis%20Stops%20Jesus%20Cuellar&amp;body=http%3A%2F%2Fwww.boxing.com%2Fdavis_tkos_cuellar.html" title="E-mail"><img src="/images/social-bookmarks/email.png" alt="E-mail" /></a></li>
<li class="last"><a rel="nofollow" href="http://digg.com/submit?phase=2&amp;url=http%3A%2F%2Fwww.boxing.com%2Fdavis_tkos_cuellar.html&amp;title=Gervonta%20Davis%20Stops%20Jesus%20Cuellar&amp;bodytext=" title="Digg" target="_blank"><img src="/images/social-bookmarks/digg.png" alt="Digg" /></a></li>
</ul>
						</strong>
					</li>
				</ul>
<div style="padding-top: 18px; padding-left: 5px;">
					<div id="fb-root"></div><script src="http://connect.facebook.net/en_US/all.js#appId=179552082105900&amp;xfbml=1"></script><fb:like href="http://www.facebook.com/pages/Boxingcom/213858341985184" send="true" width="372" show_faces="false" font=""></fb:like>
</div>
                                <div style="text-align: left;margin-left: 7px;margin-top: 10px;">
<a href="https://itunes.apple.com/app/boxing-news-and-results/id562577281" style="text-decoration: none; color: #000000;padding-left: 0px;" target="_blank" class=""><img src="http://www.boxing.com/images/appstores/iphone_logo_170x57.png" border="0"></a>
<a href="https://play.google.com/store/apps/details?id=com.boxing.boxingnews" style="text-decoration: none; color: #000000;padding-left: 0px;" target="_blank" class="clearfix"><img src="http://www.boxing.com/images/appstores/android_logo_170x57.png" border="0"></a>
<a href="http://www.windowsphone.com/en-us/store/app/boxing-news/89df1812-4fec-4b7c-911a-026d07d83aba" style="text-decoration: none; color: #000000;padding-left: 0px;" target="_blank"><img src="http://www.boxing.com/images/appstores/wp8_logo_170x57.png" border="0" width="170"></a>
<a href="http://appworld.blackberry.com/webstore/content/30183888/" style="text-decoration: none; color: #000000;padding-left: 0px;" target="_blank" class="clearfix"><img src="http://www.boxing.com/images/appstores/bb10_logo_170x57.png" border="0" width="170"></a>
</div>
                                
                                
<div style="padding-top:10px; padding-left:17px;">

<script type="text/javascript"><!--
google_ad_client = "ca-pub-0736880289040706";
/* Boxing.com Article Top Right */
google_ad_slot = "1767697332";
google_ad_width = 336;
google_ad_height = 280;
//-->
</script>
<script type="text/javascript"
src="http://pagead2.googlesyndication.com/pagead/show_ads.js">
</script>

    
    
    
</div>







			    				<h2 class="index_title">Fighter's Info</h2>
				
				<div class="fighters_info fighters_info_story">
					
					<ul id="fighters_tabs" class="fighters_tabs clearfix">
					    						<li class="active_tab" id="fighter-info-1">
							<div class="wr">
								<h3>Gervonta Davis<!--http://api.fightsrec.com/gervonta-davis.html--></h3>
								<img src="http://www.boxing.com//images/fighter-logo.png" alt="" width="30" height="30">
							</div>
						</li>
					    					    						<li id="fighter-info-2">
							<div class="wr">
								<h3>Jesus Marcelo Andres Cuellar<!--http://api.fightsrec.com/jesus-cuellar-grand-bourg.html--></h3>
								<img src="http://www.boxing.com//images/fighter-logo.png" alt="" width="30" height="30">
							</div>
						</li>
					    					</ul>

					<div class="fighters_info_story_wrap">
					    
						<div id="box-fighter-info-1" class="box-fighter-info">							<table class="fighter-info">
											<tr>
							<td class="left">Origin</td>
							<td>USA</td>
						</tr>
						<tr>
							<td class="left">Date of Birth(Age)</td>
							<td>1994.11.07&nbsp;(24)</td>
						</tr>
						<tr>
							<td class="left">Rated at</td>
							<td>Featherweight</td>
						</tr>
						<tr>
							<td class="left">W-L-D</td>
							<td><i class="win">W11</i>+<i class="lose">L0</i>+D0=11</td>
						</tr>
																									</table>
							<h3>Recent fights:</h3>
							<table id="fighters_info" class="stats">
								<tr>
									<th class="first">Date</th>
									<th>Opponent</th>
									<th>WLD</th>
									<th>Result</th>
									<th class="last">Rnds.</th>
								</tr>
										    								<tr>
									<td>2015.05.22</td>
									<td class="fighter"><a target="_blank" href="http://www.fightsrec.com/alberto-mora-baja-california.html" class="showfightersinfo">Alberto&nbsp;Mora</a></td>
									<td><i class="win">5</i>-<i class="lose">3</i>-0</td>
									<td><span class="fgreen">
									W(TKO)									</span></td>
									<td>1/8</td>
								</tr>
					    										    								<tr>
									<td>2015.02.20</td>
									<td class="fighter"><a target="_blank" href="http://www.fightsrec.com/israel-suarez.html" class="showfightersinfo">Israel&nbsp;Suarez</a></td>
									<td><i class="win">4</i>-<i class="lose">4</i>-2</td>
									<td><span class="fgreen">
									W(KO)									</span></td>
									<td>1/6</td>
								</tr>
					    										    								<tr>
									<td>2014.10.08</td>
									<td class="fighter"><a target="_blank" href="http://www.fightsrec.com/german-meraz.html" class="showfightersinfo">German&nbsp;Meraz</a></td>
									<td><i class="win">47</i>-<i class="lose">31</i>-1</td>
									<td><span class="fgreen">
									W(UD)									</span></td>
									<td>6/6</td>
								</tr>
					    										    								<tr>
									<td>2014.08.01</td>
									<td class="fighter"><a target="_blank" href="http://www.fightsrec.com/" class="showfightersinfo">Hector&nbsp;Lopez</a></td>
									<td><i class="win"></i>-<i class="lose"></i>-</td>
									<td><span class="fgreen">
									W(KO)									</span></td>
									<td>1/4</td>
								</tr>
					    										    								<tr>
									<td>2014.05.16</td>
									<td class="fighter"><a target="_blank" href="http://www.fightsrec.com/joshua-arocho.html" class="showfightersinfo">Joshua&nbsp;Arocho</a></td>
									<td><i class="win">3</i>-<i class="lose">9</i>-4</td>
									<td><span class="fgreen">
									W(RTD)									</span></td>
									<td>2/4</td>
								</tr>
					    										    								<tr>
									<td>2013.12.14</td>
									<td class="fighter"><a target="_blank" href="http://www.fightsrec.com/james-franks.html" class="showfightersinfo">James&nbsp;Franks</a></td>
									<td><i class="win">2</i>-<i class="lose">8</i>-1</td>
									<td><span class="fgreen">
									W(TKO)									</span></td>
									<td>2/</td>
								</tr>
					    										    										    										    										    										    													
							</table>
							<div align="right"><a target="_blank" href="http://www.fightsrec.com/gervonta-davis.html">See more details »</a></div></div>

					    					    
						<div id="box-fighter-info-2" class="box-fighter-info" style="display: none;">							<table class="fighter-info">
											<tr>
							<td class="left">Origin</td>
							<td>Jose C Paz Buenos Aires Argentina</td>
						</tr>
						<tr>
							<td class="left">Date of Birth(Age)</td>
							<td>1986.12.28&nbsp;(32)</td>
						</tr>
						<tr>
							<td class="left">Rated at</td>
							<td>Featherweight</td>
						</tr>
						<tr>
							<td class="left">W-L-D</td>
							<td><i class="win">W27</i>+<i class="lose">L1</i>+D0=28</td>
						</tr>
												<tr>
							<td class="left">Height</td>
							<td>5 feet 6 inches</td>
						</tr>
																		<tr>
							<td class="left">Reach</td>
							<td>68 inches</td>
						</tr>
																			</table>
							<h3>Recent fights:</h3>
							<table id="fighters_info" class="stats">
								<tr>
									<th class="first">Date</th>
									<th>Opponent</th>
									<th>WLD</th>
									<th>Result</th>
									<th class="last">Rnds.</th>
								</tr>
										    								<tr>
									<td>2015.06.06</td>
									<td class="fighter"><a target="_blank" href="http://www.fightsrec.com/vic-darchinyan.html" class="showfightersinfo">Vic&nbsp;Darchinyan</a></td>
									<td><i class="win">40</i>-<i class="lose">7</i>-1</td>
									<td><span class="fgreen">
									W(KO)									</span></td>
									<td>8/12</td>
								</tr>
					    										    								<tr>
									<td>2014.12.20</td>
									<td class="fighter"><a target="_blank" href="http://www.fightsrec.com/ruben-tamayo.html" class="showfightersinfo">Ruben&nbsp;Tamayo</a></td>
									<td><i class="win">25</i>-<i class="lose">4</i>-4</td>
									<td><span class="fgreen">
									W(TKO)									</span></td>
									<td>5/12</td>
								</tr>
					    										    								<tr>
									<td>2014.09.11</td>
									<td class="fighter"><a target="_blank" href="http://www.fightsrec.com/juan-lopez-juanma.html" class="showfightersinfo">Juan Manuel&nbsp;Lopez</a></td>
									<td><i class="win">34</i>-<i class="lose">4</i>-0</td>
									<td><span class="fgreen">
									W(KO)									</span></td>
									<td>2/12</td>
								</tr>
					    										    								<tr>
									<td>2014.05.02</td>
									<td class="fighter"><a target="_blank" href="http://www.fightsrec.com/rico-ramos.html" class="showfightersinfo">Rico&nbsp;Ramos</a></td>
									<td><i class="win">23</i>-<i class="lose">3</i>-0</td>
									<td><span class="fgreen">
									W(UD)									</span></td>
									<td>12/12</td>
								</tr>
					    										    								<tr>
									<td>2013.08.23</td>
									<td class="fighter"><a target="_blank" href="http://www.fightsrec.com/claudio-marrero.html" class="showfightersinfo">Claudio&nbsp;Marrero</a></td>
									<td><i class="win">14</i>-<i class="lose">0</i>-0</td>
									<td><span class="fgreen">
									W(UD)									</span></td>
									<td>12/12</td>
								</tr>
					    										    								<tr>
									<td>2012.12.12</td>
									<td class="fighter"><a target="_blank" href="http://www.fightsrec.com/gustavo-gonzalez-el-lagarto-asesino.html" class="showfightersinfo">Gustavo Daniel&nbsp;Gonzalez</a></td>
									<td><i class="win">11</i>-<i class="lose">4</i>-2</td>
									<td><span class="fgreen">
									W(TKO)									</span></td>
									<td>1/8</td>
								</tr>
					    										    										    										    										    										    										    										    										    										    										    										    										    										    										    										    										    										    										    										    										    										    										    													
							</table>
							<div align="right"><a target="_blank" href="http://www.fightsrec.com/jesus-cuellar-grand-bourg.html">See more details »</a></div></div>

					    					</div>
					
				</div>
			    
<img src="http://www.boxing.com/counter.php?id=47485" border="0" height="1" width="1" />



				<h2 class="index_title">Most Popular</h2>

	<ul>				<ul class="most_popular">
					<li class="clearfix">
						<span class="preview linline">
<a href="http://www.boxing.com/how_to_box_by_joe_louis_part_1the_foundation_of_skill.html">
					
					<img src="/images/sized/images/articles/joe_louis_how_to_box1-80x53.jpg" alt="How to Box by Joe Louis: Part 1—The Foundation of Skill" width="80" height="53" />

					</a>
						</span>
						<span class="wr rinline">
							<span class="title"><a href="http://www.boxing.com/how_to_box_by_joe_louis_part_1the_foundation_of_skill.html">How to Box by Joe Louis: Part 1—The Foundation of Skill</a></span>
							<span class="by">By <a href="http://www.boxing.com/Matt-McGrain-writer-17672/">Matt McGrain</a></span>

						</span>
					</li>
				</ul>
	
					<ul class="most_popular">
					<li class="clearfix">
						<span class="preview linline">
<a href="http://www.boxing.com/the_longest_fight.html">
					
					<img src="/images/sized/images/articles/Gans_Nelson_GOLDFIELD2-80x53.jpg" alt="Boxing by the Book: The Longest Fight" width="80" height="53" />

					</a>
						</span>
						<span class="wr rinline">
							<span class="title"><a href="http://www.boxing.com/the_longest_fight.html">Boxing by the Book: The Longest Fight</a></span>
							<span class="by">By <a href="http://www.boxing.com/Gordon-Marino-writer-331/">Gordon Marino</a></span>

						</span>
					</li>
				</ul>
	
					<ul class="most_popular">
					<li class="clearfix">
						<span class="preview linline">
<a href="http://www.boxing.com/don_jordan_assassin_for_hire.html">
					
					<img src="/images/sized/images/articles/don_jordan_2_sharpen-80x53.jpg" alt="Don Jordan: Assassin for Hire" width="80" height="53" />

					</a>
						</span>
						<span class="wr rinline">
							<span class="title"><a href="http://www.boxing.com/don_jordan_assassin_for_hire.html">Don Jordan: Assassin for Hire</a></span>
							<span class="by">By <a href="http://www.boxing.com/Mike-Casey-writer-392/">Mike Casey</a></span>

						</span>
					</li>
				</ul>
	</ul>

 								<h2 class="index_title">Newsletter SignUp</h2>

				<div id="newsletter">
<form id="mailinglist_form" method="post" action="http://www.boxing.com/"  >
<div class='hiddenFields'>
<input type="hidden" name="XID" value="d578196af9b697c51d79cc28b4760b238708afe4" />
<input type="hidden" name="ACT" value="21" />
<input type="hidden" name="RET" value="http://www.boxing.com/news/comments/davis_tkos_cuellar" />
<input type="hidden" name="list" value="default" />
<input type="hidden" name="site_id" value="1" />
</div>


					<form method="post" action="">
						Boxing.com Newsletter SignUp
						<div class="inner clearfix">
							<input class="field linline" type="text" name="email" value="Enter your E-mail address" />
							<input class="button rinline" type="submit" name="submit" value="SignUp" />
						</div>
					</form>
</form>
				</div>


				          
                                                                                                 
                                <h2 class="index_title">Fight results</h2>                                         
				<table id="fight_results" class="stats"> 
					<tr> 
						<th class="name">Fighters</th> 
						<th>Result</th> 
						<th>Rounds</th> 
						<th class="record">Record</th> 
 
					</tr> 
										</table>
				                                                                                                          
                                                                                                              


                                <div style="text-align: left;margin-left: 7px;margin-top: 10px;">
<a href="https://itunes.apple.com/app/boxing-news-and-results/id562577281" style="text-decoration: none; color: #000000;padding-left: 0px;" target="_blank" class=""><img src="http://www.boxing.com/images/appstores/iphone_logo_170x57.png" border="0"></a>
<a href="https://play.google.com/store/apps/details?id=com.boxing.boxingnews" style="text-decoration: none; color: #000000;padding-left: 0px;" target="_blank" class="clearfix"><img src="http://www.boxing.com/images/appstores/android_logo_170x57.png" border="0"></a>
<a href="http://www.windowsphone.com/en-us/store/app/boxing-news/89df1812-4fec-4b7c-911a-026d07d83aba" style="text-decoration: none; color: #000000;padding-left: 0px;" target="_blank"><img src="http://www.boxing.com/images/appstores/wp8_logo_170x57.png" border="0" width="170"></a>
<a href="http://appworld.blackberry.com/webstore/content/30183888/" style="text-decoration: none; color: #000000;padding-left: 0px;" target="_blank" class="clearfix"><img src="http://www.boxing.com/images/appstores/bb10_logo_170x57.png" border="0" width="170"></a>
</div>
			</div>
		</div>

<!--CONTENT_END-->
	</div>	
</div>
<div id="footer" class="wrap">
	<div class="inner clearfix">
		
		<ul class="col">
			<li><h2>About Boxing.com</h2></li>
			<li><a href="http://www.boxing.com/about">Contact Us</a></li>
			<li><a href="http://www.boxing.com/about/space-for-sale">Advertising</a></li>
			<li><a href="http://www.boxing.com/about/privacy">Privacy and Terms of Use</a></li>
			<li><a href="http://www.boxing.com/links">Boxing Links</a></li>
		</ul>

		
		<ul class="col">
			<li><h2>Writing for BOXING.com</h2></li>
			<li><a href="http://www.boxing.com/real_writers_wanted.html">Want to Write for Boxing.com?</a></li>
			<li><a href="http://www.boxing.com/write_report_for_boxing.com.html">Want to Contribute?</a></li>
			<li><a href="http://www.boxing.com/write_report_for_boxing.com.html">Post Your Story</a></li>
		</ul>
		
		<ul class="col">
			<li><h2>Explore BOXING.com</h2></li>
			<li><a href="http://www.boxing.com/video">Boxing Video</a></li>
			<li><a href="http://www.boxing.com/schedule">Boxing Schedule</a></li>
			<li><a href="http://www.boxing.com/results">Boxing Fight Results</a></li>
			<li><a href="http://www.boxing.com/about/newsletter">Boxing.com Newsletters</a></li>
		</ul>
		
		<ul class="col">
			<li><h2>Popular Boxing Topics</h2></li>

			<li>		<a href="http://www.boxing.com/pacquiao_bradley_corruption_hidden_in_plain_sight.html">Corruption Hidden in Plain Sight</a></li>

			<li>		<a href="http://www.boxing.com/pacquiao_robbednow_nobody_is_safe.html">Pacquiao Robbed—Now Nobody Is Safe</a></li>

			<li>		<a href="http://www.boxing.com/ripoff_bradley_decisions_pacquiao.html">Ripoff: Bradley Decisions Pacquiao?</a></li>

		</ul>
		
	</div>
	<div class="copy">
		<a href="#">BOXING.COM</a> &copy; 2012<br />
		Any commercial use or distribution without the express written consent of Boxing.com is strictly prohibited.
	</div>

</div>
<div id="fighter-info-box">                                                                             
    <div class="fighter-info-box">                                                                      
    </div>                                                                                              
</div>
<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-30088745-1']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>
</div> <!-- ending #content_wrapper -->
</div> <!-- ending #page -->
</body>
</html>
