<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
 <meta name="viewport" content="width=930">
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta names="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="apple-itunes-app" content="app-id=562577281" />
<meta name="google-play-app" content="app-id=com.boxing.boxingnews" />
<meta name="apple-touch-icon" href="/apple-touch-icon.png" />
<link rel="apple-touch-icon-precomposed" href="/apple-touch-icon.png" />

	<title>Why Boys Should Fight - Boxing.com</title>
	<meta name="description" content="Boxing news about Why Boys Should Fight by Johnathan Lee Iverson at Boxing.com. Ultimate Source for Latest Boxing News" />
	<meta name="keywords" content="Boxing, reyes macho time boxing club, Michael Buffer, Jimmy Lennon Jr., ring announcer, usa boxing, johnathan lee iverson, boxing news" />
<!-- CSS -->
<link href="http://www.boxing.com/css/general.css" rel="stylesheet" type="text/css" media="screen"/>
<link rel="stylesheet" href="http://www.boxing.com/css/jquery.smartbanner.css" type="text/css" media="screen">
	<link href="http://www.boxing.com/css/article.css" rel="stylesheet" type="text/css" />
<script type="text/javascript" src="http://www.boxing.com/js/jquery-1.8.3.min.js"></script>
<script type="text/javascript" src="http://www.boxing.com/js/jquery.smartbanner.js"></script>
<script type="text/javascript" src="http://www.boxing.com/js/common.js"></script>
<!--[if IE 6]>
<script type="text/javascript" src="http://www.boxing.com/js/belatedpng.js"></script>
<![endif]-->
<!--[if IE 6]>
<script type="text/javascript">
	DD_belatedPNG.fix('#header a.logo,#rotator .desc');
</script>
<![endif]-->
<script type="text/javascript" src="http://www.boxing.com/js/buysellads.js"></script>
	<script type="text/javascript" src="http://www.boxing.com/js/article.js"></script>
	<script type="text/javascript" src="https://apis.google.com/js/plusone.js"></script>
<!-- RSS -->
<link href="http://www.boxing.com/news/rss" rel="alternate" type="application/rss+xml" title="RSS Feed" />
<!-- Favicon -->

	      
</head>
	
	<body>
<div id="wrap" class="wrap">
	<div id="main">
<div id="mobile-message" style="display: none; z-index: 16777271; position: fixed; top: 0px; width: 920px; text-align: center; border: none; background-color: rgb(245, 221, 136); color: rgb(0, 0, 0); overflow: hidden; text-align: center; font-size: 3.5em; font-family: arial; padding: 0 0 8px 0; ">
Please check our <a href="https://itunes.apple.com/app/boxing-news-and-results/id562577281" style="color: #000; font-weight: bold; text-decoration: none; border-bottom: 1px solid #000;" rel="nofollow">iPhone/iPad</a>,<br><a href ="https://play.google.com/store/apps/details?id=com.boxing.boxingnews" style="color: #000; font-weight: bold; text-decoration: none; border-bottom: 1px solid #000;" rel="nofollow">Android</a> and <a href="http://www.boxing.com/m/index.php" style="color: #000; font-weight: bold; text-decoration: none; border-bottom: 1px solid #000;">Web mobile</a> versions.
<a id="mobile-close" href="#" onclick="this.parentNode.style.display = 'none'; return false;" style="display: block; width: 2em; height: 1.6em; background-color: rgb(180, 141, 4); border: none; color: rgb(255, 255, 255); text-decoration: none; position: absolute; right: 0px; top: 0px; ">×</a>
</div>
<script type="text/javascript">
if( document.referrer != null && !/boxing\.com/i.test(document.referrer) && /webOS|BlackBerry|Mobile|phone|mini/i.test(navigator.userAgent) && !/Android|iphone|iPad|iPod|/i.test(navigator.userAgent) ) {
document.getElementById("mobile-message").style.display = 'block';
}
</script>

<div style="text-align: center;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Boxing.com Leaderboard -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-0736880289040706"
     data-ad-slot="2210863252"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

		<div id="header">
			<h1 class="linline">
				<a class="logo" title="Main Page Boxing.com" href="http://www.boxing.com/">Boxing.com</a>
			</h1>
			<ul class="menu rinline">
				<li><a href="http://www.boxing.com/latest-news">NEWS</a></li>
				<li><a href="http://www.boxing.com/blog">BLOG</a></li>
				<li><a href="http://www.boxing.com/ranking">RANKING</a></li>
				<li><a href="http://www.boxing.com/schedule">SCHEDULE</a></li>
				<li><a href="http://www.boxing.com/results">RESULTS</a></li>
				<li><a href="http://www.boxing.com/video">VIDEO</a></li>
				<li><a href="http://www.boxing.com/exclusive">EXCLUSIVE</a></li>
			</ul>
		</div>
		<div id="subheader">
			<form method="post" action="">

				<div class="linline">
					<b>FIGHTS:</b>
<span class="fighter_1"><a href="http://www.boxing.com/what_to_watch_january_26.html">Keith Thurman vs. Josesito Lopez</a>





</span>
				</div>

				<ul class="rinline">
					<li class="tw"><a href="http://twitter.com/#!/Boxing_com" target="_blank"><img src="http://www.boxing.com//images/twitter.png" height="16" width="16" alt=""/></a><span class="for_ie6"></span></li>
					<li class="fb"><a href="http://www.facebook.com/pages/Boxingcom/213858341985184" target="_blank"><img src="http://www.boxing.com//images/facebook.jpg" height="16" width="16" alt=""/></a></li>
					<li><a href="http://www.boxing.com/member/register">Sign Up</a></li>
					<li class="last"><a href="http://www.boxing.com/member/login">Log In</a></li>

					<li class="search">
<form method="post" action="http://www.boxing.com/"  >
<div class='hiddenFields'>
<input type="hidden" name="ACT" value="20" />
<input type="hidden" name="XID" value="dd0bd0bc64de0b59b7dc4a2a9cbfa427ee66f290" />
<input type="hidden" name="RES" value="4" />
<input type="hidden" name="meta" value="YTo4OntzOjY6InN0YXR1cyI7czowOiIiO3M6NzoiY2hhbm5lbCI7czoyMzoid2VibmV3c3xuZXdzfHZpZGVvfGJsb2ciO3M6OToic2VhcmNoX2luIjtzOjEwOiJldmVyeXdoZXJlIjtzOjU6IndoZXJlIjtzOjM6ImFsbCI7czoxMjoic2hvd19leHBpcmVkIjtzOjA6IiI7czoxOToic2hvd19mdXR1cmVfZW50cmllcyI7YjowO3M6MTE6InJlc3VsdF9wYWdlIjtzOjE0OiJzZWFyY2gvcmVzdWx0cyI7czoxNToibm9fcmVzdWx0c19wYWdlIjtzOjE0OiJzZWFyY2gvcmVzdWx0cyI7fWQyYjg3OWYyMjlkMTJjZDgwYjZkOWM1MGQ3ZjMxY2U1" />
<input type="hidden" name="site_id" value="1" />
</div>


						<input class="search_field" type="text" name="keywords" value="Search..." onFocus="if(this.value == 'Search...'){this.value='';}"/>
						<input class="search_button" type="submit" name="submit" value=" " />
</form>
					</li>
				</ul>
			</form>
		</div>
<!--CONTENT_START-->

<div id="content" class="clearfix">
			<div class="index linline">

				<div class="post">

					<h2 class="title">Why Boys Should Fight</h2>
                                        					<div class="data">By <a href="http://www.boxing.com/Johnathan-Lee-Iverson-writer-80580/">Johnathan Lee Iverson</a> on January 25, 2019</div>
                                        
					
					<img src="/images/sized/images/articles/ali_boy-530x317.jpg" alt="Why Boys Should Fight" width="530" height="317" />

															<div class="review">
						If I dare to make any noise in this arena, I’ve got to pay my dues. (Gordon Parks) 
					</div>
										<div id="fb-root" style="padding-top: 10px;"></div><script src="http://connect.facebook.net/en_US/all.js#appId=179552082105900&amp;xfbml=1"></script><fb:like href="http://www.facebook.com/pages/Boxingcom/213858341985184" send="true" width="500" show_faces="false" font=""></fb:like>
										    					<div class="info">
					    
						<p>Recently, I was invited to preside over the Reyes Macho Time Boxing Club’s amateur bouts in Tampa, Florida…</p>


					    
					</div>
					    					<div class="story">
					    
						<p>I’m in hot pursuit of a closeted dream of mine: Ring Announcer! Let’s just say in my former life I was privileged to emcee and host some rather extraordinary people and things and the urge to continue to do so, has yet to subside. Personally, I doubt it ever will. The way I figure it, the great Michael Buffer and the legendary Jimmy Lennon, Jr. have crafted remarkable legacies worth aspiring to, so why not? </p>

<p>Like all things, you have to start somewhere. I can’t rest on my pedigree. Ring announcing is a completely different kind of business and if I dare to make any noise in this arena, I’ve got to pay my dues just like everyone else. Recently, I was invited to preside over the Reyes Macho Time Boxing Club’s amateur bouts in Tampa, Florida. This would be my first foray into the squared circle as an announcer. A mix of excitement and curiosity blended within me, as I’ve grown accustomed to expect the unexpected. I wasn’t so worried as to how I might fair in this new venture, but rather if I could appreciate it at this level. What was supposed to be a card of nearly 25 bouts ended up being 8. Minor logistical matters arose, but nothing that wasn’t swiftly and effortlessly handled. It was clear the organizers, which included USA Boxing were well acquainted with the <em>unexpected</em>. I knew I was in my element.</p>

<p>Fighters and coaches situated themselves, as one would expect—reviewing paperwork, running through their check ups with the fight doctor on duty, and of course warming up and reviewing prospective fight plans. Everything was in place, including English and Spanish speaking commentators. There was the pesky inconvenience of their National Anthem singer bailing at the last minute (or maybe he/she didn’t show). It didn’t matter. I know that song like I know my name, so I stepped in and performed it. </p>

<p>From the second I stepped in to the ring until I exited for the final match, it was effortless. It was clear that my efforts were well received. More importantly it was a great card of fights. The officiating was precise and the combatants purported themselves gallantly and as great sportsmen. I was privileged to interview the winners of each match. Everyone was well spoken and humble, still displaying their youthful innocence though they possess such vicious ability. Judging from the talent I saw, we can officially do away with the silly notion of boxing’s demise. It has a very bright future. Better still, having observed the rapport between the respective coaches and their charges and even the bond between the fighters themselves, I think we may very well be witnessing the grooming of some standup men.</p>

<p>It is not lost on anyone who hasn’t been living under a rock that lately, the narrative on men, manhood, or all things masculine has been quite grim. “Toxic Masculinity” is the newest term adopted by this sound bite obsessed culture of ours. One has to wonder though, if behind every great man there is a great woman, how is it that when he’s “toxic” there’s no one to be found to account for him? I’ll leave that for the intellectuals to ponder. </p>

<p>Without a doubt, boxing would likely be thought of among the activities this new thought pantheon believes constitutes or contributes to <em>toxic masculinity</em>. I’m always baffled by the squeamish and uninitiated souls that cast well-articulated, but misinformed dispersions upon things they truly do not understand or even care to know. My time announcing those amateur bouts at The Reyes Macho Time Boxing Club further corroborated my belief in the combat arts or sports in general, as one of the ideal tools in the cultivation of boys to men. What I saw and enjoyed were adult coaches with a clear respect and knowledge of their charges; and in turn, how receptive those charges were. To actually hear a coach belt out instructions to his fighter, who then enacts those instructions with immediate perfection testifies, not only to well practiced craftsmanship, but that boy’s ability to adhere to well intended leadership and that coach’s ability to show himself worthy of that trust. What I saw as gym mates rallied for one another, not at the expense of their opponents, or the display of sincere of sportsmanship, were boys who are being trained to understand that a man’s power lies not merely in what he might have to <em>beat down</em> in defense of self or others, but more often than not, by what or who he lifts up. What I saw were boys, though defeated, learning to comb the lessons of disappointment and not lose their dignity in the process.</p>

<p>What our society must come to grips with is that manhood doesn’t just happen. We don’t get to surmise the whole of the masculine experience with a sound bite. Manhood, like anything else worthwhile, requires cultivation. There are so many dynamic facets that go into the make up of a man that too often go ignored or repressed, particularly that which encourages and fosters his warrior or competitive spirit. Perhaps, if we gave proper space, as opposed to condemnation or shaming, to the fine-tuning and guidance that spirit requires we wouldn’t have to bear witness to its many tragic misuses.</p>
					    
											</div>
					<div>
<em>Follow us on <a href="http://twitter.com/#!/boxing_com" target="_blank" >Twitter@boxing_com</a> to continue the discussion</em>
</div>
<br>
		        

					
				</div>
<div class="tags" style="">
Tags: 

<a href="/tag/reyes+macho+time+boxing+club">reyes macho time boxing club</a> 

<a href="/tag/Michael+Buffer">Michael Buffer</a> 

<a href="/tag/Jimmy+Lennon+Jr.">Jimmy Lennon Jr.</a> 

<a href="/tag/ring+announcer">ring announcer</a> 

<a href="/tag/usa+boxing">usa boxing</a> 

<a href="/tag/johnathan+lee+iverson">johnathan lee iverson</a> 

<br><br>
</div>

<div style="padding-bottom: 15px;">
<ul class="social_bookmarks">
<li class="first"><a rel="nofollow" href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fwww.boxing.com%2Fwhy_boys_should_fight.html&amp;t=Why%20Boys%20Should%20Fight" title="Facebook" target="_blank" onclick="window.open(this.href,'_blank','height=520,width=570');return false;"><img src="/images/social-bookmarks/facebook.png" alt="Facebook" /></a></li>
<li><a rel="nofollow" href="http://twitter.com/share?url=http%3A%2F%2Fwww.boxing.com%2Fwhy_boys_should_fight.html&amp;text=Why%20Boys%20Should%20Fight:" title="Twitter" target="_blank" onclick="window.open(this.href,'_blank','height=520,width=570');return false;"><img src="/images/social-bookmarks/twitter.png" alt="Twitter" /></a></li>
<li><a rel="nofollow" href="http://www.linkedin.com/shareArticle?mini=true&amp;url=http%3A%2F%2Fwww.boxing.com%2Fwhy_boys_should_fight.html&amp;title=Why%20Boys%20Should%20Fight&amp;source=Boxing.com&amp;summary=" title="LinkedIn" target="_blank" onclick="window.open(this.href,'_blank','height=520,width=570');return false;"><img src="/images/social-bookmarks/linkedin.png" alt="LinkedIn" /></a></li>
<li><g:plusone size="small" count="false"></g:plusone></li>
<li><a rel="nofollow" href="http://pinterest.com/pin/create/button/?url=http%3A%2F%2Fwww.boxing.com%2Fwhy_boys_should_fight.html&amp;media=http%3A%2F%2Fwww.boxing.com%2Fimages%2Farticles%2Fali_boy.jpg&amp;description=Why%20Boys%20Should%20Fight" title="Pinterest" target="_blank"><img src="/images/social-bookmarks/pinterest.png" alt="Pinterest" /></a></li>
<li><a rel="nofollow" href="mailto:?subject=Why%20Boys%20Should%20Fight&amp;body=http%3A%2F%2Fwww.boxing.com%2Fwhy_boys_should_fight.html" title="E-mail"><img src="/images/social-bookmarks/email.png" alt="E-mail" /></a></li>
<li><a rel="nofollow" href="http://del.icio.us/post?url=http%3A%2F%2Fwww.boxing.com%2Fwhy_boys_should_fight.html&amp;title=Why%20Boys%20Should%20Fight&amp;notes=" title="Del.icio.us" target="_blank"><img src="/images/social-bookmarks/delicious.png" alt="Del.icio.us" /></a></li>
<li><a rel="nofollow" href="http://digg.com/submit?phase=2&amp;url=http%3A%2F%2Fwww.boxing.com%2Fwhy_boys_should_fight.html&amp;title=Why%20Boys%20Should%20Fight&amp;bodytext=" title="Digg" target="_blank"><img src="/images/social-bookmarks/digg.png" alt="Digg" /></a></li>
<li><a rel="nofollow" href="http://www.evernote.com/clip.action?url=http%3A%2F%2Fwww.boxing.com%2Fwhy_boys_should_fight.html&amp;title=Why%20Boys%20Should%20Fight" title="Evernote" target="_blank"><img src="/images/social-bookmarks/evernote.png" alt="Evernote" /></a></li>
<li><a rel="nofollow" href="http://www.friendfeed.com/share?title=Why%20Boys%20Should%20Fight&amp;link=http%3A%2F%2Fwww.boxing.com%2Fwhy_boys_should_fight.html" title="FriendFeed" target="_blank"><img src="/images/social-bookmarks/friendfeed.png" alt="FriendFeed" /></a></li>
<li><a rel="nofollow" href="http://www.friendster.com/sharer.php?u=http%3A%2F%2Fwww.boxing.com%2Fwhy_boys_should_fight.html&amp;t=Why%20Boys%20Should%20Fight" title="Friendster" target="_blank"><img src="/images/social-bookmarks/friendster.png" alt="Friendster" /></a></li>
<li><a rel="nofollow" href="http://www.google.com/bookmarks/mark?op=edit&amp;bkmk=http%3A%2F%2Fwww.boxing.com%2Fwhy_boys_should_fight.html&amp;title=Why%20Boys%20Should%20Fight&amp;annotation=" title="Google Bookmarks" target="_blank"><img src="/images/social-bookmarks/google.png" alt="Google Bookmarks" /></a></li>
<li><a rel="nofollow" href="https://favorites.live.com/quickadd.aspx?marklet=1&amp;url=http%3A%2F%2Fwww.boxing.com%2Fwhy_boys_should_fight.html&amp;title=Why%20Boys%20Should%20Fight" title="Windows Live" target="_blank"><img src="/images/social-bookmarks/live.png" alt="Windows Live" /></a></li>
<li><a rel="nofollow" href="http://www.myspace.com/Modules/PostTo/Pages/?u=http%3A%2F%2Fwww.boxing.com%2Fwhy_boys_should_fight.html&amp;t=Why%20Boys%20Should%20Fight" title="MySpace" target="_blank"><img src="/images/social-bookmarks/myspace.png" alt="MySpace" /></a></li>
<li><a rel="nofollow" href="http://www.netvibes.com/share?title=Why%20Boys%20Should%20Fight&amp;url=http%3A%2F%2Fwww.boxing.com%2Fwhy_boys_should_fight.html" title="Netvibes" target="_blank"><img src="/images/social-bookmarks/netvibes.png" alt="Netvibes" /></a></li>
<li><a rel="nofollow" href="http://www.newsvine.com/_tools/seed&amp;save?u=http%3A%2F%2Fwww.boxing.com%2Fwhy_boys_should_fight.html&amp;h=Why%20Boys%20Should%20Fight" title="Newsvine" target="_blank"><img src="/images/social-bookmarks/newsvine.png" alt="Newsvine" /></a></li>
<li><a rel="nofollow" href="http://posterous.com/share?linkto=http%3A%2F%2Fwww.boxing.com%2Fwhy_boys_should_fight.html&amp;title=Why%20Boys%20Should%20Fight&amp;selection=" title="Posterous" target="_blank"><img src="/images/social-bookmarks/posterous.png" alt="Posterous" /></a></li>
<li><a rel="nofollow" href="http://reddit.com/submit?url=http%3A%2F%2Fwww.boxing.com%2Fwhy_boys_should_fight.html&amp;title=Why%20Boys%20Should%20Fight" title="Reddit" target="_blank"><img src="/images/social-bookmarks/reddit.png" alt="Reddit" /></a></li>
<li><a rel="nofollow" href="http://sphinn.com/index.php?c=post&amp;m=submit&amp;link=http%3A%2F%2Fwww.boxing.com%2Fwhy_boys_should_fight.html" title="Sphinn" target="_blank"><img src="/images/social-bookmarks/sphinn.png" alt="Sphinn" /></a></li>
<li><a rel="nofollow" href="http://www.stumbleupon.com/submit?url=http%3A%2F%2Fwww.boxing.com%2Fwhy_boys_should_fight.html&amp;title=Why%20Boys%20Should%20Fight" title="StumbleUpon" target="_blank"><img src="/images/social-bookmarks/stumbleupon.png" alt="StumbleUpon" /></a></li>
<li><a rel="nofollow" href="http://www.tumblr.com/share?v=3&amp;u=http%3A%2F%2Fwww.boxing.com%2Fwhy_boys_should_fight.html&amp;t=Why%20Boys%20Should%20Fight&amp;s=" title="Tumblr" target="_blank"><img src="/images/social-bookmarks/tumblr.png" alt="Tumblr" /></a></li>
<li><a rel="nofollow" href="http://vkontakte.ru/share.php?url=http%3A%2F%2Fwww.boxing.com%2Fwhy_boys_should_fight.html&amp;title=Why%20Boys%20Should%20Fight" title="VKontakte" target="_blank" onclick="window.open(this.href,'_blank','height=260,width=570');return false;"><img src="/images/social-bookmarks/vkontakte.png" alt="VKontakte" /></a></li>
<li class="last"><a rel="nofollow" href="http://bookmarks.yahoo.com/toolbar/savebm?opener=tb&amp;u=http%3A%2F%2Fwww.boxing.com%2Fwhy_boys_should_fight.html&amp;t=Why%20Boys%20Should%20Fight&amp;d=" title="Yahoo! Bookmarks" target="_blank"><img src="/images/social-bookmarks/yahoo.png" alt="Yahoo! Bookmarks" /></a></li>
</ul>
</div>


<div style="padding-bottom: 15px;">
<a href="http://www.boxing.com/forums/viewthread/7686">Discuss this in our forums</a>
</div>



				<h2 class="index_title">Related Articles</h2>
				<ul class="related_articles clearfix">
					<li style="min-height: 114px;">

						<a href="http://www.boxing.com/seeing_is_believing.html">
										<img src="http://www.boxing.com/images/articles/BronerPac2001abc-0-3.jpg" alt="" width="120" height="72" />
												<span class="title">Seeing Is Believing</span>
						</a>

					</li>

					<li style="min-height: 114px;">

						<a href="http://www.boxing.com/adrien_bronerpink_elephants.html">
										<img src="http://www.boxing.com/images/articles/Pacquiao_vs_Broner_-_Jan._19__2019_01_19_2019_Fight_Ryan_Hafey___Premier_Boxing_Champions_2_.jpg" alt="" width="120" height="72" />
												<span class="title">Adrien Broner—Pink Elephants</span>
						</a>

					</li>

					<li style="min-height: 114px;">

						<a href="http://www.boxing.com/the_jack_reiss_show.html">
										<img src="http://www.boxing.com/images/articles/wilder_fury_jack_reiss.jpg" alt="" width="120" height="72" />
												<span class="title">The Jack Reiss Show</span>
						</a>

					</li>

					<li style="min-height: 114px;">

						<a href="http://www.boxing.com/apparently_big_daddy_wants_that_smoke.html">
										<img src="http://www.boxing.com/images/articles/Bowe-Lewis_10-2-88a_WP-31.jpg" alt="" width="120" height="72" />
												<span class="title">Apparently, “Big Daddy” Wants That Smoke</span>
						</a>

					</li>
</ul>







<script type="text/javascript"><!--
google_ad_client = "ca-pub-0736880289040706";
/* Boxing.com Comment */
google_ad_slot = "5265270696";
google_ad_width = 530;
google_ad_height = 74;
//-->
</script>
<script type="text/javascript"
src="http://pagead2.googlesyndication.com/pagead/show_ads.js">
</script>



<div style="padding-right: 18px;">

<a name="comments"></a>
			
						<h2 class="index_title">Comments</h2>
<div style="font-weight: bold; margin-bottom:10px;">
This is a place to express and/or debate your boxing views. It is not a place to offend anyone. If we feel comments are offensive, the post will be deleted and continuing offenders will be blocked from the site. Please keep it clean and civil! We want to have fun. We want some salty language and good-natured exchanges. But let's keep our punches above the belt...</div>
			<ol class="comments">				<li>
					<a name="c115861"></a>
					<h5 class="commentdata">
						<a href="#">peter</a>
						<span>07:13am,  01/25/2019</span>
											</h5>
					<p>Thank you for sharing your well-phrased thoughts. It is so refreshing to read such an enlightened and upbeat article. Much needed! What is &#8220;toxic&#8221; today is not masculinity, it is the &#8220;toxic&#8221; environment we all find ourselves swimming in. Strong, virtuous, honest, masculinity is actually the antidote to today&#8217;s toxic woes.<br />
This was a great line: &#8220;One has to wonder though, if behind every great man there is a great woman, how is it that when he’s “toxic” there’s no one to be found to account for him?&#8221;</p>
                    <div style="clear: both;"></div>
				</li>
						
							<li>
					<a name="c115859"></a>
					<h5 class="commentdata">
						<a href="#">Mau-Mauing The Flak Catchers</a>
						<span>06:32am,  01/25/2019</span>
											</h5>
					<p>&#8220;Toxic masculinity&#8221; is yet another ridiculous MANUFACTURED mind f*ck brought to you by the USUAL SUSPECTS bent on destroying Western Culture. Of course these same cretins see no problem with a huge transgender male to female rugby player bashing women half his/her size on the field. These same problem solvers wring their hands about what to do with other kids being bullied, but yet will punish a kid if he gives the bully a much needed beat down. A recent event saw a teen age boy chastised for &#8220;standing his ground.&#8221; Somehow &#8220;standing your ground&#8221; and not cowering is &#8220;aggressive&#8221; and provocative. Fighting is not encouraged, especially in an environment as violent and unpredictable  like we live in, but it is and has always been a part of being a man whether you like it or not. Like that old Kenny Rogers song said,&nbsp; &#8220;sometimes you have to fight to be a man.&#8221; hehe. Teaching your kid to avoid fights whenever possible is responsible teaching, teaching your kid to never fight is unreasonable and unrealistic.</p>
                    <div style="clear: both;"></div>
				</li>
			</ol>			

				
				
				<h2 class="index_title">Leave a comment</h2>

			<form id="comment_form" method="post" action="http://www.boxing.com/"  >
<div class='hiddenFields'>
<input type="hidden" name="ACT" value="16" />
<input type="hidden" name="RET" value="http://www.boxing.com/news/comments/why_boys_should_fight" />
<input type="hidden" name="URI" value="news/comments/why_boys_should_fight" />
<input type="hidden" name="PRV" value="news/comment_preview" />
<input type="hidden" name="XID" value="64d3ce97e2e6b829ca79cc3d7d1f304f27f20913" />
<input type="hidden" name="entry_id" value="51609" />
<input type="hidden" name="site_id" value="1" />
</div>


			    <fieldset id="comment_fields">
							<label for="name" style="display:block; font-size:13px">
					<input class="field" type="text" id="name" name="name" value="Your Name" size="50" onclick="if(this.value='Your Name') this.value='';" />
				</label>
				<label for="email">
					<input class="field" type="text" id="email" name="email" value="Email" size="50" onclick="if(this.value='Email') this.value='';" />
				</label>
				<label for="location">
					 <input class="field" type="text" id="location" name="location" value="Location" size="50" onclick="if(this.value='Location') this.value='';" />
				</label>
				<label for="url">
					<input class="field" type="text" id="url" name="url" value="Website" size="50" onclick="if(this.value='Website') this.value='';" />
				</label>
									
							<label for="comment" class="comment">
					<textarea id="comment" class="field" style="" name="comment" rows="10" cols="70"></textarea>
							</label>
						    </fieldset>

			    <fieldset id="comment_action">
			    								<label for="save_info"><input class="field" style="width: 10px;height: 10px;" type="checkbox" name="save_info" value="yes"  />&nbsp;Remember my personal info?  </label>
								<label for="notify_me"><input class="field" style="width: 10px;height: 10px;" type="checkbox" id="notify_me" name="notify_me" value="yes"  />&nbsp;Notify me of follow-up comments </label>

								<div id="captcha_box">
				    <span><img src="http://www.boxing.com/images/captchas/1548432756.3619.jpg" width="140" height="30" style="border:0;" alt=" " /></span>
				</div>
				<label for="captcha">Please <a href="http://www.boxing.com/member/login">login</a> or enter the word you see in the image above:
				    <input class="field" type="text" id="captcha" name="captcha" value="" maxlength="20" />
				</label>
								<input class="button" type="submit" name="submit" value="Submit" id="submit_comment" />
							    	
			    </fieldset>
			</form>



				
</div>
			</div>
			<div class="sidebar rinline">
				

				<ul class="fb_like clearfix">
					<li>
						<strong>109</strong>reads
					</li>

					<li>
						<a href="#comments"><strong>2</strong>comments</a>
					</li>
					<li class="bookmark">
						<strong><ul class="social_bookmarks">
<li class="first"><a rel="nofollow" href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fwww.boxing.com%2Fwhy_boys_should_fight.html&amp;t=Why%20Boys%20Should%20Fight" title="Facebook" target="_blank" onclick="window.open(this.href,'_blank','height=520,width=570');return false;"><img src="/images/social-bookmarks/facebook.png" alt="Facebook" /></a></li>
<li><a rel="nofollow" href="http://twitter.com/share?url=http%3A%2F%2Fwww.boxing.com%2Fwhy_boys_should_fight.html&amp;text=Why%20Boys%20Should%20Fight:" title="Twitter" target="_blank" onclick="window.open(this.href,'_blank','height=520,width=570');return false;"><img src="/images/social-bookmarks/twitter.png" alt="Twitter" /></a></li>
<li><a rel="nofollow" href="http://www.linkedin.com/shareArticle?mini=true&amp;url=http%3A%2F%2Fwww.boxing.com%2Fwhy_boys_should_fight.html&amp;title=Why%20Boys%20Should%20Fight&amp;source=Boxing.com&amp;summary=" title="LinkedIn" target="_blank" onclick="window.open(this.href,'_blank','height=520,width=570');return false;"><img src="/images/social-bookmarks/linkedin.png" alt="LinkedIn" /></a></li>
<li><g:plusone size="small" count="false"></g:plusone></li>
<li><a rel="nofollow" href="http://pinterest.com/pin/create/button/?url=http%3A%2F%2Fwww.boxing.com%2Fwhy_boys_should_fight.html&amp;media=http%3A%2F%2Fwww.boxing.com%2Fimages%2Farticles%2Fali_boy.jpg&amp;description=Why%20Boys%20Should%20Fight" title="Pinterest" target="_blank"><img src="/images/social-bookmarks/pinterest.png" alt="Pinterest" /></a></li>
<li><a rel="nofollow" href="mailto:?subject=Why%20Boys%20Should%20Fight&amp;body=http%3A%2F%2Fwww.boxing.com%2Fwhy_boys_should_fight.html" title="E-mail"><img src="/images/social-bookmarks/email.png" alt="E-mail" /></a></li>
<li class="last"><a rel="nofollow" href="http://digg.com/submit?phase=2&amp;url=http%3A%2F%2Fwww.boxing.com%2Fwhy_boys_should_fight.html&amp;title=Why%20Boys%20Should%20Fight&amp;bodytext=" title="Digg" target="_blank"><img src="/images/social-bookmarks/digg.png" alt="Digg" /></a></li>
</ul>
						</strong>
					</li>
				</ul>
<div style="padding-top: 18px; padding-left: 5px;">
					<div id="fb-root"></div><script src="http://connect.facebook.net/en_US/all.js#appId=179552082105900&amp;xfbml=1"></script><fb:like href="http://www.facebook.com/pages/Boxingcom/213858341985184" send="true" width="372" show_faces="false" font=""></fb:like>
</div>
                                <div style="text-align: left;margin-left: 7px;margin-top: 10px;">
<a href="https://itunes.apple.com/app/boxing-news-and-results/id562577281" style="text-decoration: none; color: #000000;padding-left: 0px;" target="_blank" class=""><img src="http://www.boxing.com/images/appstores/iphone_logo_170x57.png" border="0"></a>
<a href="https://play.google.com/store/apps/details?id=com.boxing.boxingnews" style="text-decoration: none; color: #000000;padding-left: 0px;" target="_blank" class="clearfix"><img src="http://www.boxing.com/images/appstores/android_logo_170x57.png" border="0"></a>
<a href="http://www.windowsphone.com/en-us/store/app/boxing-news/89df1812-4fec-4b7c-911a-026d07d83aba" style="text-decoration: none; color: #000000;padding-left: 0px;" target="_blank"><img src="http://www.boxing.com/images/appstores/wp8_logo_170x57.png" border="0" width="170"></a>
<a href="http://appworld.blackberry.com/webstore/content/30183888/" style="text-decoration: none; color: #000000;padding-left: 0px;" target="_blank" class="clearfix"><img src="http://www.boxing.com/images/appstores/bb10_logo_170x57.png" border="0" width="170"></a>
</div>
                                
                                
<div style="padding-top:10px; padding-left:17px;">

<script type="text/javascript"><!--
google_ad_client = "ca-pub-0736880289040706";
/* Boxing.com Article Top Right */
google_ad_slot = "1767697332";
google_ad_width = 336;
google_ad_height = 280;
//-->
</script>
<script type="text/javascript"
src="http://pagead2.googlesyndication.com/pagead/show_ads.js">
</script>

    
    
    
</div>







			    
<img src="http://www.boxing.com/counter.php?id=51609" border="0" height="1" width="1" />



				<h2 class="index_title">Most Popular</h2>

	<ul>				<ul class="most_popular">
					<li class="clearfix">
						<span class="preview linline">
<a href="http://www.boxing.com/is_floyd_mayweather_a_coward.html">
					
					<img src="/images/sized/images/articles/floyd-mayweather-buys-bentley-golf-cart-for-son-_sh-80x53.jpg" alt="Is Floyd Mayweather a “Coward?”" width="80" height="53" />

					</a>
						</span>
						<span class="wr rinline">
							<span class="title"><a href="http://www.boxing.com/is_floyd_mayweather_a_coward.html">Is Floyd Mayweather a “Coward?”</a></span>
							<span class="by">By <a href="http://www.boxing.com/Johnathan-Lee-Iverson-writer-80580/">Johnathan Lee Iverson</a></span>

						</span>
					</li>
				</ul>
	
					<ul class="most_popular">
					<li class="clearfix">
						<span class="preview linline">
<a href="http://www.boxing.com/boxing_in_glorious_black_and_white.html">
					
					<img src="/images/sized/images/articles/Lesnevich_4sh-80x53.jpg" alt="Boxing in Glorious Black and White" width="80" height="53" />

					</a>
						</span>
						<span class="wr rinline">
							<span class="title"><a href="http://www.boxing.com/boxing_in_glorious_black_and_white.html">Boxing in Glorious Black and White</a></span>
							<span class="by">By <a href="http://www.boxing.com/Clarence-George-writer-67513/">Clarence George</a></span>

						</span>
					</li>
				</ul>
	
					<ul class="most_popular">
					<li class="clearfix">
						<span class="preview linline">
<a href="http://www.boxing.com/the_crafty_battling_nelson.html">
					
					<img src="/images/sized/images/articles/Nelson_copy_3_sh-80x53.jpg" alt="The Crafty Battling Nelson" width="80" height="53" />

					</a>
						</span>
						<span class="wr rinline">
							<span class="title"><a href="http://www.boxing.com/the_crafty_battling_nelson.html">The Crafty Battling Nelson</a></span>
							<span class="by">By <a href="http://www.boxing.com/Pete-Ehrmann-writer-80653/">Pete Ehrmann</a></span>

						</span>
					</li>
				</ul>
	</ul>

 								<h2 class="index_title">Newsletter SignUp</h2>

				<div id="newsletter">
<form id="mailinglist_form" method="post" action="http://www.boxing.com/"  >
<div class='hiddenFields'>
<input type="hidden" name="XID" value="b123720efc1bf7b882bd244929609311e3b2376b" />
<input type="hidden" name="ACT" value="21" />
<input type="hidden" name="RET" value="http://www.boxing.com/news/comments/why_boys_should_fight" />
<input type="hidden" name="list" value="default" />
<input type="hidden" name="site_id" value="1" />
</div>


					<form method="post" action="">
						Boxing.com Newsletter SignUp
						<div class="inner clearfix">
							<input class="field linline" type="text" name="email" value="Enter your E-mail address" />
							<input class="button rinline" type="submit" name="submit" value="SignUp" />
						</div>
					</form>
</form>
				</div>


				          
                                                                                                 
                                <h2 class="index_title">Fight results</h2>                                         
				<table id="fight_results" class="stats"> 
					<tr> 
						<th class="name">Fighters</th> 
						<th>Result</th> 
						<th>Rounds</th> 
						<th class="record">Record</th> 
 
					</tr> 
										</table>
				                                                                                                          
                                                                                                              


                                <div style="text-align: left;margin-left: 7px;margin-top: 10px;">
<a href="https://itunes.apple.com/app/boxing-news-and-results/id562577281" style="text-decoration: none; color: #000000;padding-left: 0px;" target="_blank" class=""><img src="http://www.boxing.com/images/appstores/iphone_logo_170x57.png" border="0"></a>
<a href="https://play.google.com/store/apps/details?id=com.boxing.boxingnews" style="text-decoration: none; color: #000000;padding-left: 0px;" target="_blank" class="clearfix"><img src="http://www.boxing.com/images/appstores/android_logo_170x57.png" border="0"></a>
<a href="http://www.windowsphone.com/en-us/store/app/boxing-news/89df1812-4fec-4b7c-911a-026d07d83aba" style="text-decoration: none; color: #000000;padding-left: 0px;" target="_blank"><img src="http://www.boxing.com/images/appstores/wp8_logo_170x57.png" border="0" width="170"></a>
<a href="http://appworld.blackberry.com/webstore/content/30183888/" style="text-decoration: none; color: #000000;padding-left: 0px;" target="_blank" class="clearfix"><img src="http://www.boxing.com/images/appstores/bb10_logo_170x57.png" border="0" width="170"></a>
</div>
			</div>
		</div>

<!--CONTENT_END-->
	</div>	
</div>
<div id="footer" class="wrap">
	<div class="inner clearfix">
		
		<ul class="col">
			<li><h2>About Boxing.com</h2></li>
			<li><a href="http://www.boxing.com/about">Contact Us</a></li>
			<li><a href="http://www.boxing.com/about/space-for-sale">Advertising</a></li>
			<li><a href="http://www.boxing.com/about/privacy">Privacy and Terms of Use</a></li>
			<li><a href="http://www.boxing.com/links">Boxing Links</a></li>
		</ul>

		
		<ul class="col">
			<li><h2>Writing for BOXING.com</h2></li>
			<li><a href="http://www.boxing.com/real_writers_wanted.html">Want to Write for Boxing.com?</a></li>
			<li><a href="http://www.boxing.com/write_report_for_boxing.com.html">Want to Contribute?</a></li>
			<li><a href="http://www.boxing.com/write_report_for_boxing.com.html">Post Your Story</a></li>
		</ul>
		
		<ul class="col">
			<li><h2>Explore BOXING.com</h2></li>
			<li><a href="http://www.boxing.com/video">Boxing Video</a></li>
			<li><a href="http://www.boxing.com/schedule">Boxing Schedule</a></li>
			<li><a href="http://www.boxing.com/results">Boxing Fight Results</a></li>
			<li><a href="http://www.boxing.com/about/newsletter">Boxing.com Newsletters</a></li>
		</ul>
		
		<ul class="col">
			<li><h2>Popular Boxing Topics</h2></li>

			<li>		<a href="http://www.boxing.com/pacquiao_bradley_corruption_hidden_in_plain_sight.html">Corruption Hidden in Plain Sight</a></li>

			<li>		<a href="http://www.boxing.com/pacquiao_robbednow_nobody_is_safe.html">Pacquiao Robbed—Now Nobody Is Safe</a></li>

			<li>		<a href="http://www.boxing.com/ripoff_bradley_decisions_pacquiao.html">Ripoff: Bradley Decisions Pacquiao?</a></li>

		</ul>
		
	</div>
	<div class="copy">
		<a href="#">BOXING.COM</a> &copy; 2012<br />
		Any commercial use or distribution without the express written consent of Boxing.com is strictly prohibited.
	</div>

</div>
<div id="fighter-info-box">                                                                             
    <div class="fighter-info-box">                                                                      
    </div>                                                                                              
</div>
<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-30088745-1']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>
</div> <!-- ending #content_wrapper -->
</div> <!-- ending #page -->
</body>
</html>
